Ankündigung

Einklappen
Keine Ankündigung bisher.

WIN XP system32\config\system beschädigt - schon wieder

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • WIN XP system32\config\system beschädigt - schon wieder

    Hi, liebe Community =)

    Ihr konntet mir bisher sehr gut helfen, deswegen melde ich mich hier.


    Habe einen PC neu gemacht und XP neu installiert. Nun trat es auf, dass er XP nicht booten wollte, weil eine Datei beschädigt oder nicht da sei. In dem Fall ist es ein Ordner. Also HDD an einen anderen PC gehangen: Ordner ist da, lässt sich nicht öffnen "das Verzeichnis sei leer", lässt sich nicht löschen "das Verzeichnis sei nicht leer". Schon mal wieder dummes Windoofgeningel. Also per cmd versucht den Ordner zu listen: "beschädigt, chkdsk ausführen". Also HDD überprüft, Verzeichnisse wurden wiederhergestellt und PC lief wieder.

    Nun aber tritt das selbe Problem erneut auf. Wenn ich weiß woher das kommt - vor dem PC hatte ich das noch nie erlebt.
    Avira Free ist jedenfalls aktuell und das System ist in keiner gefährdeten Umgebung: andere XP Systeme im Netzwerk laufen ohne dieses Problem. Bei der Installation gab es keine Schwierigkeiten. Die Platte ist übrigens eine SSD von OCZ S-ATA II mit 110GB und der Controller läuft im IDE-Modus.

    Mehr fällt mir vom Weitem erstmal nicht ein. Finde es nur lästig, dass es selbst zu doof ist eine Datenträgerüberpüfung durchzuführen in dem Fall. Der Fehler ist so schnell behoben. Man braucht eine andere Systempartition dazu, es sei denn man mag kompliziertere Wege -.-
    Von denen sehe ich aber ab.

    Ich mag wissen wie ich verhindern kann, dass der Fehler überhaupt auftritt.

    Übrigens hab ich dem Nutzer des PCs keine Adminrechte vergeben.

    LG & ein schönes WE weiterhin =)
    Danke für jede Antwort.

  • #2
    Ich würde in so einem Fall erst einmal von einem Defekt oder zumindest Problem der SSD ausgehen. Jedenfalls sofern du den Rechner auch immer richtig herunter fährst, und nicht einfach abstellst, ansonsten kommt so etwas natürlich auch mal ganz gern vor.

    So ein Problem sollte also normalerweise nie auftreten, und wenn doch, dann sollte der Weg zur Lösung kein Aufruf von CheckDisk sein, sondern das Beheben des Hardwaredefektes.

    Eventuell gibt es für die SSD ein Firmware-Update? Man hört so etwas ja öfter. Ansonsten (wenn möglich) umtauschen oder Ersatz beschaffen.

    Kommentar


    • #3
      Zitat von Kelshan Beitrag anzeigen
      Ich würde in so einem Fall erst einmal von einem Defekt oder zumindest Problem der SSD ausgehen. Jedenfalls sofern du den Rechner auch immer richtig herunter fährst, und nicht einfach abstellst, ansonsten kommt so etwas natürlich auch mal ganz gern vor.

      So ein Problem sollte also normalerweise nie auftreten, und wenn doch, dann sollte der Weg zur Lösung kein Aufruf von CheckDisk sein, sondern das Beheben des Hardwaredefektes.

      Eventuell gibt es für die SSD ein Firmware-Update? Man hört so etwas ja öfter. Ansonsten (wenn möglich) umtauschen oder Ersatz beschaffen.
      Der zweite Ansatz ist der Controller. Ist zwar schön einfach, den Controller im IDE-Modus zur Installation eines alten Systems wie Win XP zu verwenden und sich so im Normalfall die Treiberfrage bei der Installation zu schenken, für eine SSD sollte der Controller aber idealerweise halt im SATA-Modus laufen.

      Das Problem ist ansonsten weitläufig bekannt als Cache-Problem bei älteren Platten. Windows fährt runter und schaltet ab, bevor der Cache auf die Platte runtergeschrieben ist. Der beschädigte Teil im von dir genannten Pfad ist übrigens die Registrierung - die kann auch ohne weiteres mal nicht mehr von ChkDsk gerettet werden und dann installierst du eh neu.

      Als letzten Hinweis hätte ich noch: Falls der Controller von Intel ist, die in der Systray eingenistete Zusatzsoftware deinstallieren/deaktivieren und nur den Treiber verwenden. Diese Software kann bei bestimmten Konfigurationen genau denselben Effekt erzielen wie das Problem mit dem Cache älterer Platten - Software will noch was "optimieren" und Windows sagt "aus!" - Ergebnis gleich.
      Karl Ranseier ist tot. Der wohl erfolgloseste Foren-Autor aller Zeiten wurde heute von einem Bus auf der Datenautobahn überfahren.

      Star Wars 7? 8? Spin-Offs? Leute, das Haftmittel für meine Dritten macht bessere Filme!

      Kommentar


      • #4
        Zitat von Karl Ranseier Beitrag anzeigen
        Der zweite Ansatz ist der Controller. Ist zwar schön einfach, den Controller im IDE-Modus zur Installation eines alten Systems wie Win XP zu verwenden und sich so im Normalfall die Treiberfrage bei der Installation zu schenken, für eine SSD sollte der Controller aber idealerweise halt im SATA-Modus laufen.
        Meine Wissens nach gibt es noch den AHCI Modus. Weiß aber von hier aus nicht ob der Boardcontroller überhaupt Ahnung von sowas hat. Hab den PC ja nicht hier.


        Zitat von Karl Ranseier Beitrag anzeigen
        Der beschädigte Teil im von dir genannten Pfad ist übrigens die Registrierung - die kann auch ohne weiteres mal nicht mehr von ChkDsk gerettet werden[...]
        Ulkiger Weise eben in dem Fall schon. Wie ich schon beschrieben habe. Gibt schöne Lösungen für das Problem die viel mit dem regedit zu tun haben und die hab ich auch in Betracht gezogen gehabt beim ersten auftreten des Fehlers. Aber dann hat CheckDisk das ganz allein behoben und alles war gut.

        Das mit der Firmware ist allerdings mal einen Blick wert. Das mach ich mal. Wobei die Platte bereits getauscht wurde.... nja man kann ja Glück haben.

        Ansonsten hab ich vor eine Startdiskette anzulegen für erneutes Auftreten dessen -.- Ich weiß: "aufgeschoben ist nicht aufgehoben" aber ist ja nicht mein PC. Ich hab nur den Auftrag erhalten mit dem geringsten finanziellen Aufwand die schnellste Kiste hinzustellen. Das da ein AM2 X2 mit SSD und XP bei rauskommt liegt zum einen daran, dass ich das Zeug da hatte, zum anderen leider an der Unverträglichkeit des alten Boards mit Win 7 -.-

        Vielen Dank erstmal und bisher hab ich auch keine Infos. Muss ich wohl auch mal wieder live hin. Kann schon sein, dass die Kiste echt doof ist und abschaltet bevor Windows tatsächlich fertig mit runter fahren ist oO aber das ist dann echt schon weit hergeholt.

        LG

        Kommentar


        • #5
          AHCI-Advanced Host Controller Interface. Damit werden praktisch die weiteren Funktionen aktiviert, die SATA neben der Form der Schnittstelle ausmachen, zB NCQ. Im IDE-Modus gibt's kein NCQ (weil ausserhalb vom IDE-Standard), und bei SSDs kann es da dann zum von dir beschriebenen Problem kommen (NCQ - native command queuing). Problem bei Windows ist halt: Schaltet man den Modus nachträglich um, gibt's beim Hochfahren nen Blue Screen mit dem berühmten STOP 0x0000007B - inacessible boot device. Windows findet sich dann selbst nicht mehr, weil ein anderer Gerätetreiber auf dem Zugriffsweg zur Platte benötigt wird. Wenn man weiß, wie, kann man den nachträglich in der Registrierung unterschieben (muß dafür von einem anderen Medium gebootet werden, daß wenigstens Zugriff auf regedit zuläßt, gibt da verschiedene Bootbare Rescuedisks).

          Wenn man es vor der Installation umstellt, benötigt man den vollen SATA-Treiber schon während der Installation (als .sys und .inf, nicht als setup.exe oder ähnliches) und XP kann dann halt nicht auf einen kompatiblen Treiber ausweichen (im Normalfall nicht da). In der heutigen Zeit ohne Floppy bereitet man sich da am Besten eine Installations-CD mit nLite und dem benötigten Treiber vor.
          Karl Ranseier ist tot. Der wohl erfolgloseste Foren-Autor aller Zeiten wurde heute von einem Bus auf der Datenautobahn überfahren.

          Star Wars 7? 8? Spin-Offs? Leute, das Haftmittel für meine Dritten macht bessere Filme!

          Kommentar


          • #6
            Man kann es auch nach der Installation, aber vor der Umstellung vorbereiten. Das "Unterschieben in der Registrierung" kann man auch machen wenn man im IDE-Modus gebootet hat. Anschließend stellt man es im BIOS um und alles passt. Nach der Installation sollten dann beides Modis funktionieren.

            Ist jedenfalls meine Erfahrung damit.

            Ab Vista gibt es das Problem übrigens nicht mehr.

            Ich denke allerdings auch nicht, dass das hier viel helfen wird. Ich hatte jedenfalls noch nie auch nur das geringste Problem mit dem IDE-Modus (außer dass er unter bestimmten Umständen etwas langsamer sein könnte).

            Kommentar


            • #7
              Mein Rat an dich , wenn du ne SSD hast solltest du auch Win Vista oder höher einsetzten da dort auch die Betriebssysteme darauf optimiert sind.
              Scotty Tribute muss man gesehen haben Motobi in Graz
              Graz Autowerkstatt

              Kommentar

              Lädt...
              X