Ankündigung

Einklappen
Keine Ankündigung bisher.

[Suche] Image Protection Script

Einklappen
X
  • Filter
  • Zeit
  • Anzeigen
Alles löschen
neue Beiträge

  • [Suche] Image Protection Script

    Hallo!
    Ich suche eher eine Anleitung wie ich gesamte Verzeichnisse schützen kann, dass niemand von außerhalb (sprich nicht die Domains die ich eingegeben habe) auf Bilder bzw. Dateien die von mir angegeben werden zugreift. Ich denke, dass die irgendwie mit .htaccess geht. Nur bräuchte ich dazu eine Anleitung. Das beste wäre, dass man dann auch auf ein anderes Bild wie es hier im STF ist weitergeleitet wird:


  • #2
    Das macht man mit .htaccess Files, die du uploaden musst. Das muß aber auch dein Webserver unterstützen, in der Regel machen das aber alle.

    Google sagt dazu

    Merlin
    --

    Kommentar


    • #3
      Mhh es sperrt das komplette Verzeichniss.

      Ich habe auf dem Server ein Testverzeichniss angelegt

      /test

      mit einer Bilddatei darin->test.jpg

      jetzt habe ich die .htaccess mit folgendem Inhalt hochgeladen:

      RewriteEngine on
      RewriteCond %{HTTP_REFERER} !^$
      RewriteCond %{HTTP_REFERER} !^http://logic-online.biz.*$ [NC]
      RewriteCond %{HTTP_REFERER} !^http://www.logic-online.biz.*$ [NC]
      RewriteCond %{HTTP_REFERER} !^http://riedlinger.biz.*$ [NC]
      RewriteCond %{HTTP_REFERER} !^http://www.riedlinger.biz.*$ [NC]
      RewriteCond %{HTTP_REFERER} !^http://logic.star-trek-galaxy.net.*$ [NC]
      RewriteCond %{HTTP_REFERER} !^http://www.logic.star-trek-galaxy.net.*$ [NC]
      RewriteRule .*\.(gif|jpg|jpeg|bmp|png)$ http://www.logic-online.biz/logos/banner2.gif [R,NC]
      Aber leider zeigt es auch kein Bild bei meinen angegeben Domains an geschweigedenn dann das Weiterleitunsbild.

      Kommentar


      • #4
        RewriteEngine on
        RewriteCond %{HTTP_REFERER} !^$
        RewriteCond %{HTTP_REFERER} !^http://www.scifi-forum.de/.*$ [NC]
        RewriteRule .*\.(gif|GIF|jpg|JPG|png|PNG)$ http://213.209.95.126/x.gif [R]
        Die letzte Zeile wird es sein, statt [R,NC] nur [R] und es geht in dieser Zeile leider imho nur eine IP Nummer anstatt einer kompletten Domain!

        Merlin
        --

        Kommentar


        • #5


          Sorry es geht nicht. Ich habe mal den Inhalt deiner .htaccess übernommen. Woran könnte es noch liegen?

          Kommentar


          • #6
            Das Bild wird nicht angezeigt, ok? Wo ist jetzt noch einmal genau dein Problem?

            Merlin
            --

            Kommentar


            • #7
              Original geschrieben von Merlin
              Das Bild wird nicht angezeigt, ok? Wo ist jetzt noch einmal genau dein Problem?

              Merlin
              Das das Bild nicht angezeigt wird. Ich habe folgenden .htaccess Inhalt, eben nur zum Testen:

              RewriteEngine on
              RewriteCond %{HTTP_REFERER} !^$
              RewriteCond %{HTTP_REFERER} !^http://www.scifi-forum.de/.*$ [NC]
              RewriteRule .*\.(gif|GIF|jpg|JPG|png|PNG)$ http://213.209.95.126/x.gif [R]

              Kommentar


              • #8
                Ist ja auch der Sinn, dass das Bild NICHT angezeigt wird. Oder meinst du das X Bild????

                Versuche es mal mit der IP Deines Rechners, also dem auf dem der Webserver läuft!

                Merlin
                --

                Kommentar


                • #9
                  Original geschrieben von Merlin
                  Ist ja auch der Sinn, dass das Bild NICHT angezeigt wird. Oder meinst du das X Bild????

                  Versuche es mal mit der IP Deines Rechners, also dem auf dem der Webserver läuft!

                  Merlin
                  Schaue mal das Bild sollte doch nach dem Inhalt den ich eingegen habe angezeigt werden. http://www.scifi-forum.de ist berechtigt das Bild anzuzeigen. Ich meine das X-Bild das nicht angezigt wird in meinem Post.

                  Kommentar


                  • #10
                    Ist das ein lokaler Webserver? Apache, IIS oder sonst einer?

                    Merlin
                    --

                    Kommentar


                    • #11
                      Original geschrieben von Merlin
                      Ist das ein lokaler Webserver? Apache, IIS oder sonst einer?

                      Merlin
                      Es ist ein richtiger root Webserver bei puretec.

                      Server: Apache/1.3.19 (Unix) (SuSE/Linux) mod_ssl/2.8.3 OpenSSL/0.9.6a PHP/4.2.3 mod_perl/1.25 mod_throttle/3.0 mod_layout/1.0 mod_fastcgi/2.2.2 mod_dtcl

                      Kommentar


                      • #12
                        Mal deine IP Adresse versucht und nicht meine?

                        Merlin
                        --

                        Kommentar


                        • #13
                          Original geschrieben von Merlin
                          Mal deine IP Adresse versucht und nicht meine?

                          Merlin
                          Ehm Sorry ich verstehe jetzt nicht mehr was du meinst. Das ist doch egal die IP muss doch nicht auf dem Server liegen auf das es verlinkt wird oder?

                          Kommentar


                          • #14
                            IMO schon!

                            Merlin
                            --

                            Kommentar


                            • #15
                              Original geschrieben von Merlin
                              IMO schon!

                              Merlin
                              Ich habe nämlich keine IP Adresse die ich da eintragen könnte außer die schon vom Server. Ich hatte deine ja nur zum Testen drin aber es klappt nicht.

                              Kommentar

                              Lädt...
                              X